易语言题解(滑稽)

回复帖子

@beastxiny 2019-11-09 01:30 回复

.程序集 程序集1

.子程序 _启动子程序, 整数型

.局部变量 str1, 文本型

.局部变量 str2, 文本型

.局部变量 i, 整数型

.局部变量 num, 整数型

str1 = 标准输入 ()

str2 = 标准输入 ()

.如果 (fun (str1) = fun (str2))

标准输出 (, “GO”)

.否则

标准输出 (, “STAY”)

.如果结束

标准输入 ()

返回 (0)

.子程序 fun, 整数型

.参数 str, 文本型

.局部变量 no, 整数型

.局部变量 i, 整数型

.局部变量 ret, 整数型

ret = 1

.变量循环首 (1, 取文本长度 (str), 1, i)

no = 取代码 (取文本中间 (str, i, 1), 1) - 取代码 (“A”, 1) + 1

ret = ret × no

ret = ret % 47

.变量循环尾 ()

返回 (ret)

@LRL52 2019-11-09 07:36 回复 举报

啊,易语言是我学习编程的第一门语言,虽然是自学的

反馈
如果你认为某个帖子有问题,欢迎向洛谷反馈,以帮助更多的同学。



请具体说明理由,以增加反馈的可信度。